04 Sep, 2013, js_wilson wrote in the 1st comment:
Votes: 0
I am always playing around with different codebases I find on here, and I wanted to take a look at the QuickMUD version of RoM. I downloaded it on my windows machine to take a look at the files before I upload it to my Debian VPS, untarred the file, and now I have a single file, and I don't know what to do with it. Normally, when I untar a MUD codebase, I get a few directories, with a source directory, containing a makefile, but this just gave me a single file. I tried opening it in notepad++ on my windows machine to see what was in it. It looks like all the src files are somehow attached to this one file. What do I do with it?
04 Sep, 2013, Idealiad wrote in the 2nd comment:
Votes: 0
You probably just have to unzip it. If it's the same copy I just looked at here, it's a tar'ed gzip.
04 Sep, 2013, js_wilson wrote in the 3rd comment:
Votes: 0
I tried unzipping it with 7zip, unzipped the original tar.gz file, then unzipped the .tar file, and the result was a single file, called quickmud with no file extension. I also tried this with the QuickMUD-March2012 version of the file, and got the same result. Maybe the problem is with 7zip. I will try this on my Debian VPS now, and see what happens. The quickmud file is what I opened in notepad++ that just had all the source in a single file, with a bunch of this kind of black bars that say NUL in between what I assume should be separate source files.
04 Sep, 2013, Idealiad wrote in the 4th comment:
Votes: 0
That quickmud with no file extension is the gzip. Try double-clicking it in 7zip.
04 Sep, 2013, js_wilson wrote in the 5th comment:
Votes: 0
Bingo, that did it. I'm not used to using gzip files in windows. I should just stick with linux.
04 Sep, 2013, Tyche wrote in the 6th comment:
Votes: 0
It's not Windows. It's not 7-zip. It happens if you are using Linux too. It happens with both Chrome and Firefox.
The site is broken and gzips all the downloaded files like gzipped web pages.
So what you get is a gzip of a gzip of a tar.
The only client I found that will download files correctly is Internet Explorer.
And that's because it doesn't support gzipped web pages.